挖井

类库大魔王的挖井日记

挖一口属于自己的井


不要盲目追求最新版本

  无论是软件,还是程序库,应该选定一个并不太旧的稳定版本,一段时间内,比如半年,一直使用该版本。
  一个明显的例子是之前用4.3.2版的gcc编译好的wxMSW,后来年到4.3.3版的gcc了,就下载下来试用了一下,发现原来的工程死活链接有问题,报什么虚函数找不到云云,再换回4.3.2就又可以了。由此看来,4.3.2和4.3.3编译出来的.o文件可能在内存等方面有变化。我也不想再花时间去用4.3.3编译一遍wxMSW了,太浪费时间了,而且如果要换,就要把其他相关的库都换一遍,至少包括boost,Xerces-C++,wxLua,青春啊,不能就这么耗费掉啊!

本文地址:

https://minidump.info/blog/2009/03/e4-b8-8d-e8-a6-81-e7-9b-b2-e7-9b-ae-e8-bf-bd-e6-b1-82-e6-9c-80-e6-96-b0-e7-89-88-e6-9c-ac/

感觉本文不错,不妨小额鼓励我一下!
上一篇

基于Lua的可扩展架构设计

  首先,这个架构是一定程度上模仿Eclipse的,并做了大量简化,所以模仿得并不像,不过不得不说最原始的灵感和很多想法是从它那里来的。  支撑起整个可扩展架构是一个类,大概名叫pluginsRegistry的类。这个类一般可以使用singleton模式,它做一些与插件相关的最基础最底层的事。...…

Lua,Script Plugin Framework 全文阅读
下一篇

MySQL还不错

  老雷要一个自动发汇报邮件的程序,这个任务落到我的头上,于是我这周开始整这玩意儿。所有的数据几乎都是存放在MySQL里的,一个是RedMine的内容,另一个是组里自己开发应用程序使用情况统计工具,服务器端也使用的MySQL。今天我发感叹地跟开发那应用程序使用情况统计工具的同事说,幸亏你们当时...…

Software 全文阅读